Issue with Jetcat 120SX

For items about gas turbine, IC and Electric powered jets, engines and systems

Moderator: Dick Spreadbury

simonwood
Posts: 1
Joined: Sun Nov 08, 2015 5:31 pm

Issue with Jetcat 120SX

Postby simonwood » Sat Nov 07, 2020 2:02 pm

Got a 120SX not starting. It's not starting because the pump is not pumping.

On the bench the pump runs as expected, using a bench PSU it starts turning around 0.2v. Running from the ECU nothing. Measuring the DC voltage across the pump it's zero. Pushing the start start voltage upto maximum of 0.7 and it's still 0v across the pump.

Using the test menu, purge fuel, at around 1.55v on the GSU the pump starts turning, but it is reading 0.2v DC across the pump motor terminals. Tried with 2 pumps same issue.

Is this a pump or an ECU issue ?

ECU is V6.

[everything was last working fine in Sept 2019 - took ages to source a new retract gear set, now behaving like this]

Thanks in advance for any info.

Simon.

David Gladwin
Posts: 39
Joined: Sun Aug 31, 2014 12:02 am

Re: Issue with Jetcat 120SX

Postby David Gladwin » Mon Nov 09, 2020 6:37 pm

It seems to me that if the Pump voltage to start is only .2 the ECU is not providing the correct, any , voltage, confirmed by two pumps reacting the same way. I would strongly suggest, all other things such as battery voltage being ok ( have you tried another?) that your ECU needs checking.

May just need reflashing.


Return to “Jets”

Who is online

Users browsing this forum: No registered users and 4 guests