Jets Munt 140xbl problems...!!! Help please

For items about gas turbine, IC and Electric powered jets, engines and systems

Moderators: jamie cuff, Dick Spreadbury

David Warrington
Posts: 17
Joined: Sun Jan 18, 2015 3:34 pm

Jets Munt 140xbl problems...!!! Help please

Postby David Warrington » Sat Aug 01, 2015 10:07 am

I don't know if anyone will be able to help, but it's worth a try...

I have a brand new JM 140xbl turbine that I have installed into my PRC Dolphin.

We went to the field last weekend for its maiden. I started the engine as a ground test and everything fired up and happened how it should, turned it off & it cooled down properly...all was good!

When I came to start it again, it spun the starter as normal but wouldn't ignite the Kero? I have tried it several times since and the data terminal just keeps saying "IGN FAIL" I have tried charging the ECU battery & changing it for a higher capacity, but nothing helps?

Does anyone have any ideas???

Cheers, Dave.

Martyn Ball
Posts: 11
Joined: Wed Sep 04, 2013 7:28 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby Martyn Ball » Sun Aug 02, 2015 12:59 am

When you go in to the test function and test both valves can you hear them 'tick' open?
Also, is the engine the right way up with pipe and ECU connector at the top?
And last suggestion, are you using the standard short weaved cable?

If yes to all this, no idea, im far from an expert so try info@jetmunt.com

David Warrington
Posts: 17
Joined: Sun Jan 18, 2015 3:34 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby David Warrington » Sun Aug 02, 2015 9:47 am

Hi Martyn,

Thanks for the reply. It's a Yes to all those questions I'm afraid :cry:

I think I have done all the obvious things, the only way forward now is to send it back to Gaspar in Spain....and I think they're closed for most of August :roll:

What a PITA!

Cheers, Dave.

shaun cope
Posts: 2
Joined: Thu Jun 07, 2007 11:22 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby shaun cope » Mon Aug 03, 2015 5:19 am

Hi have you tried to turn up the glow voltage ,don't go more than 6.7 if it doesn't fire then the ignighter may have gone then its needs to go back to gaspar

David Warrington
Posts: 17
Joined: Sun Jan 18, 2015 3:34 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby David Warrington » Mon Aug 03, 2015 8:40 pm

I have tried literally everything :cry:

Looks like it is going on its holidays back to Gaspar to be repaired. I'm a bit disappointed as I haven't had a reply to my email from Gaspar as yet. I am going to have to have the engine courier'd back to the factory and enclose a covering letter. It will be insured and tracked!!!

Does anyone have any advice on a courier to spain...?

shaun cope
Posts: 2
Joined: Thu Jun 07, 2007 11:22 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby shaun cope » Mon Aug 03, 2015 9:28 pm

Hi if you email sonia@xicoy.com and ask them to sort out the postage it will only cost you around €25 in stead of £100 all you have to do is pay them up front ,I paid by pay pal ,gaspar will help you as much as he can I have sent a few of mine back for one thing and another ,hope this helps

David Warrington
Posts: 17
Joined: Sun Jan 18, 2015 3:34 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby David Warrington » Tue Aug 04, 2015 12:11 am

shaun cope wrote:Hi if you email sonia@xicoy.com and ask them to sort out the postage it will only cost you around €25 in stead of £100 all you have to do is pay them up front ,I paid by pay pal ,gaspar will help you as much as he can I have sent a few of mine back for one thing and another ,hope this helps


Cheers Shaun, that's a big help!

I have been emailing info at Jetsmunt so I will forward those mails onto that address!

Thanks, Dave.

Martyn Ball
Posts: 11
Joined: Wed Sep 04, 2013 7:28 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby Martyn Ball » Tue Aug 04, 2015 9:15 am

I have exactly the same problem and its been nearly 2 weeks, I've only had one reply and I still dont know if they want it sending in.

Used to be awesome service at Jet Munt

David Warrington
Posts: 17
Joined: Sun Jan 18, 2015 3:34 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby David Warrington » Tue Aug 04, 2015 4:46 pm

Martyn Ball wrote:I have exactly the same problem and its been nearly 2 weeks, I've only had one reply and I still dont know if they want it sending in.

Used to be awesome service at Jet Munt


I am hearing of more and more issues with Jets-Munt just recently :cry:

I did quite a bit of research before buying this engine and only got glowing reports of reliability and good aftersales....Now it seems that all that is not quite the case! I do hope it is just a blip and they get it all sorted out!

Maybe they are overwhelmed with orders based on their reputation and now are struggling to meet demand?

I have had NO reply to any emails yet and have sent several! I have asked for advice on how to return the engine but have heard nothing from them....slightly frustrating!

Let's see, fingers crossed!

Martyn Ball
Posts: 11
Joined: Wed Sep 04, 2013 7:28 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby Martyn Ball » Tue Aug 04, 2015 9:58 pm

This is my 4th Merlin and the others have been perfect. I just seem to have a friday afternoon job.

All new in February and this is the 2nd failure its had. Annoying that I'm considering buying another to use as a spare now.

David Warrington
Posts: 17
Joined: Sun Jan 18, 2015 3:34 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby David Warrington » Wed Aug 05, 2015 9:27 am

Martyn Ball wrote:This is my 4th Merlin and the others have been perfect. I just seem to have a friday afternoon job.

All new in February and this is the 2nd failure its had. Annoying that I'm considering buying another to use as a spare now.


Funny you should say that! I have just got an old secondhand jet central 120 for that very reason!

Shouldn't really be paying 2 grand for a new engine then have to spend another grand on a supposedly inferior temporary replacement, so you can still fly while it's being fixed :x

David Warrington
Posts: 17
Joined: Sun Jan 18, 2015 3:34 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby David Warrington » Wed Aug 05, 2015 1:11 pm

Just an Update!

I hadn't received any correspondence today, so I sent a message via the 'contact us' section of the Xicoy website. I had a reply from Gaspar within the hour! It appears that he hadn't received any of my emails :?:

Anyway, he said that I shouldn't send the engine back until after the 20th August as they are closed (I knew that). I asked about the shipping issue and he said that Sonia would send me a label on Monday, so it is looking pretty good (fingers crossed).

So far, once I have managed to contact them, Jets-Munt seem to be living up to their reputation of Good Customer service!


I will keep you informed how it goes :|

Thanks for all your help and comments,

Dave.

David Warrington
Posts: 17
Joined: Sun Jan 18, 2015 3:34 pm

Re: Jets Munt 140xbl problems...!!! Help please

Postby David Warrington » Sun Sep 20, 2015 7:43 am

Conclusion:

My turbine is back & working perfectly 8)

Jets-Munt arranged for collection and return delivery & it didn't cost me anything. Apparently the problem was a faulty internal glow plug, which was replaced and the engine is now faultless......and bloomin good...!

Thanks for the help chaps,

Regards, Dave.


Return to “Jets”

Who is online

Users browsing this forum: No registered users and 4 guests